
Browse

The Windows Help system has the facility of Browse buttons, which can be used to guide the 
user in a particular direction, when logic would indicated that a particular sequence of Topics is 
desired. You can create browse sequences using Help Edit by defining the parent and sequence 
number of the Topics that you wish to be grouped together.



Definition

A definition in the Help system is an explanation of a word or phrase that might not be familiar 
to the user. Often this is a technical term that has specific meaning in the context in which it is 
used. When the user clicks the mouse button on words that have definitions attached to them, a 
pop up window appears giving this extra information, and remains until the user presses enter, or
clicks the mouse again.



HPJ

The Microsoft Help Compiler requires an HPJ (Help Project File) in order to create a Help file 
from your RTF files.

The HPJ file contains among other things the location of all the RTF and Bitmap files that your 
Help file needs. Help Edits Project structure means that all this information is known to it, and 
you can create an HPJ file with the minimum of effort.



HyperText

HyperText is a form of electronic book in which the reader, instead of following a pre-set path 
from beginning to end, is able to move around by means of selecting key words or phrases within
the 'Book' that perform a jump to a new location within the 'Book'.



Keywords

The Windows Help system lets the user search for a particular subject or topic by entering 
Keywords or phrases into a search window. If you add relevant keywords to your Topics, then 
these will be recognised by the Windows Help engine, and your Topic's Titles will appear in the 
search found list.



Project

Help Edit works with Project files. These file contain information about the files your Help file 
needs, and all the topic and definition information making it easier to create the HPJ file that is 
needed by the Microsoft Help Compiler.

It also makes it easier for you to keep track of your topics. The burden of creating and 
maintaining a list of topic and definition labels for your hypertext links is automated.



RTF

The Microsoft Help Compiler requires your Topic files to be in RTF (Rich Text Format).

This is a format devised by Microsoft in 1986, and is only supported by the top of the range word
processors such as Microsoft Word and WordPerfect. Help Edit removes the need for this by 
compiling your text files in a suitable RTF format.



Shareware

Shareware is a form of try before you buy. It is NOT a means of obtaining free software. 
Shareware is not free. If you find a Shareware program useful and intent to continue using it you 
are obliged to register it with the author, and pay for it.



Topic

The term Topic in this context refers to a HyperText page of information. Each Topic has a label 
by which it is accessed, and optionally a Title which can be used when performing a search.



If the word is correct, but unknown to Help Edit, you can add the word to your private 
dictionary.



If the word is correct, but not important enough to keep, eg. a post or zip code, you can simply 
ignore it.



If it is likely that the word will be repeated, you can select Ignore All, and Spelmate will place 
the word in a Temporary dictionary, and will ignore all future Occurrences.



If the Edit control box of the suggestion list contains the word you want, you can select change 
and Help Edit will replace the old word in your text with this new word.



Select Cancel to end the spell check, the cursor will be placed at the point spell checking started.



This is the word the spell checker did not recognise in your text.



The spell checker will offer a list of words from the dictionary that is closest to the word it does 
not recognise.



Help Button
This button will invoke the On-Line Help for Help Edit. It is the same as Choosing Help Index 
from the Help Menu.



Open Project
This button opens a Project. It has the same effect as choosing Open from the Project Menu.



Save File
This button will save the contents of the editor. It has the same effect as choosing Save From the 
File menu. This button will not be active is the editor text has not changed.



Cut Text
This button will cut the selected text to the Clipboard. It has the same effect as selecting Cut 
from the Edit menu. This button will not be active if there is no text selected.



Copy Text
This button will copy the selected text to the Clipboard. It has the same effect as selecting Copy 
from the Edit menu. This button will not be active if there is no text selected.



Paste Text
This button will copy text from the Clipboard. It has the same effect as selecting Paste from the 
Edit menu. This button will not be active if there is no text in the clipboard.



Make Topic
This button has the same effect as selecting Topic from the Make Menu.



Make Definition
This button has the same effect as selecting Definition from the Make Menu.



Insert Bitmap
This button has the same effect as selecting Bitmap from the Insert Menu.



Make Help
This button will make your help file by calling the Help Compiler



Test Help
This button will run your help file



Check Spelling
This button will invoke the Spell Checker.
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The Tool Bar
The Tool bar has the following control buttons.

Click on each button for more information on what each one does.



The Status Bar
The Status bar gives the following information.

In the first section is the Line number and Column position.

In the second section the word 'Modified' appears when the user has changes the text in the 
editor.

In the third section, a description of each menu item is given when that menu item is highlighted.

The last three sections indicate the status of the CAPS lock, NUM lock and SCROLL lock keys 
respectively.



The File Menu

The File Menu allows you to create new Help files and has the following options

Open
Save
Save As
Printer Set-up
Print
Exit

Select each Name for further information.



Edit Menu

The Edit menu allows you to edit the text file and has the following options

Undo
Cut
Copy
Paste
Delete
Clear All
Topic
Definition
Word Wrap

Select each Name for further information



Word Wrap
Use this menu selection to toggle Word Wrap On/Off.

When word wrap is on, text will wrap to the next line when it reaches the edge of the Window. If
word wrap is off, text will scroll to the left. When On there will be a check mark next to the 
menu item, and no horizontal scroll bar. During Save, Help Edit temporarily turns word wrap off,
so that there are no false line breaks in your help file.



Search Menu

The Search menu offers the following choices

Find
Replace
Next

Select each Name for further information



Project Menu

The Project menu offers the following menu items

Open
Close
Add File
Delete File
Remove Topic
Remove Definition
Current :- [None]

Select each Name for further information



Make Menu

The Make menu contains the following options

Topic
Title
Definition
HELP File

Select each Name for further information



Insert Menu

The insert menu has the following selections

Jump Link
Definition Link
BitMap Image
Paragraph Indent

Select each Name for further information



Choose Font

You must have selected text before you can activate this menu.

You will be presented with a dialog box offering a choice of Fonts, character sizes, colours, and 
attributes such as Bold, Underline, strikeout, and Italic. After you have made your choice select 
OK to insert the RTF codes, or Cancel to quit. You should use Fonts and Colours sparingly.

An example of what is available is shown below.

Arial,red,24 point
Courier, blue,underline,15 point

Courier New, fuschia,bold,strikeout,22 point
Fixed Sys, normal, 9 point

MS Sans Serif, navy,underline,bold,24 point

MS Serif, green, bold, italic, 24 point
Small Fonts, black, bold, 7 point
System, Lime green,underline,bold,10 point

Times New Roman, Gray,italic,36 point



The Options Menu

This menu has the following selections.

Choose Font
Spell Check.
Select Editor.
Windows 3.1

Click on any of the above for more information.



Select Editor.

During compilation of your Help topics into a Help File by the Help compiler, Help Edit routes 
all Warning and Error messages into a file called Helpedit.err.

If Help Edit detects any errors or warnings it uses the default editor to show these messages. The 
default editor is Notepad. You can use this option to select another editor, e.g. WinEdit or Write.

Help Edit will remember your changes and use the editor of your choice in future sessions.

Just use the file selection box to tell Help Edit the name and location of your editor.



Spell Check

If you have the professional version of Help Edit, you will also have Spelmate, a spell checking 
DLL installed. This comes in both American and British versions. It has a 50,000 word plus 
dictionary, and a private user dictionary that you can add your own definitions to.

To spell check your Help Edit document, place the cursor at the point you wish to begin the spell 
check, then select the Spell check menu item from the Options menu.
Help Edit will load the spell checker and scan you text. If it encounters an unknown word it will 
make suggestions as to what it might be, and you can accept a word form the suggestion list, and 
Help Edit will replace the word for you.

The Spelmate dialog is shown below, it is an example of a .SHG file that Help Edit supports. 
Click on the various controls for more information.

When you reach the end of the spell check a dialog box will announce that spelling is complete. 
You can cancel at any time before then by selecting the cancel button.



Windows 3.1

If you are using the Windows 3.1 version of the help compiler you should select this option.

A check mark will be placed next to the menu entry, and when you exit Help Edit the 
information will be saved, so that you need not re-enter it.

The HPJ file is different for Windows 3.0 and 3.1 help compilers, and so Help Edit needs to 
know which one you intend to use. You should also refer to the HC.BAT file setup to make sure 
that Help Edit calls the correct compiler for you.

Help Edit also uses this information when allowing certain options to be selected, such as 
launching a program from within your Help File. As this is a macro command only available in 
Version 3.1.



Help Menu

The Help Menu has the following items

About
Help Index
Help on Help
Order
Shareware
Tutorial
Test Help

Select each Name for further information



File New

This option starts a new file. Any previous file contents will be cleared.

If you have a file in memory that has changed, you will be asked if you wish to save the data.

You should Open a Project first. When Help Edit starts up you can begin entering text 
immediately, but you will not be able to save it until you supply a Project Name.



File Open

Select Open to load an existing Help Edit file from the Project.

Use this option to Load a file listed in the Project. This option can only be selected if a valid 
project is open, and it contains at least one file.
A list of Text files will be presented in a list box, and you should select one, or cancel.



File Save

Use this menu option to save the current file being edited.If you do not have a Project open at the
time you save the file , you will be asked to open or create a new Project so that the name of the 
file you have just saved can be added.

If the file was new, you will be prompted for a file name. The Filename will automatically be 
added to the project list.



File Save As

This menu item allows you to save the current file under a new name. 



File Printer Set-up

This option allows you to select a particular printer, and optionally set it up for portrait or 
landscape mode, depending on the printer options available.



File Print

This option prints the contents of the edit window. If you select a piece of text first, then select 
the Selected Text option from the print dialog, then only the selected text will be printed.



File Exit
This option will end the Help Edit session. If there is a file in memory that has changed, you will 
be asked if you wish to save it.



Edit Undo

This option allows you to undo the last edit command, if at all possible.

Some edit commands such as Cut and Copy are saved in a buffer, and it is possible to undo the 
last command.



Edit Cut

To perform a Cut, you must first select the text to cut. This will then be highlighted.
The text is deleted from the edit file, and copied into the clipboard. From there it can be pasted 
into a new location.



Edit Copy

To perform a Copy, you must first select the text to copy. This will then be highlighted.
This is similar to Edit Cut in that the selected text is copied into the clipboard. The original text 
remains unchanged. The copied text can then be pasted from the clipboard into another location.



Edit Paste

The Paste command copies any text in the clipboard into the file at the current caret(text cursor) 
position.

This option is only available if the clipboard contains valid text data.



Edit Delete

The Delete command deletes the selected text from the edit file. It is not copied to the clipboard.



Edit Clear All

This command clears all the contents of the editor. You will be warned if you have not saved 
your data.



Edit Topic

This option allows you to change a Topic.
A list box of Topics will be presented and you should select the Topic you wish to Edit.

A dialog box will appear similar to the one used when creating a Topic, only all the fields will be 
completed with the data of the Topic selected. You can alter the Title, the list of Keywords, or 
alter the Browse sequence. If you choose OK the edit changes will be implemented, choose 
Cancel to abort the edit.



Edit Definition

A dialog box will appear similar to the one used when creating a Definition, only the Title field 
will be completed with the data of the Definition selected. You can alter the Title, and if you 
choose OK the edit changes will be implemented, choose Cancel to abort the edit.



Search Find

Use search find to locate a word or piece of text in the file. You will be presented with a dialog 
box requesting the text to find. There is the option to match case.



Search Replace

This option allows you to replace a single or all occurrences of one text string with another 
string. You will be presented with a dialog box asking for the old and the new text.

Options include matching case, single or all occurrences, and you can choose whether or not you 
want to confirm each substitution.



Search Next

The search find function will select the first occurrence of the text that matches it's goal. If you 
want to look for subsequent occurrences, select this menu item.

Use the hot key F3 to save time.



Project Open

Every Help Edit session requires the use of a Project File. This file holds information regarding 
the files in you Help system, and also the Topics and Definitions that you create.

This makes the creation of a HPJ project file for the Help compiler an almost automated process, 
and thus makes your job much easier.

This menu option allows you to load a project file, or to create a new one by typing in a new 
name. The *.prj extension is automatically added. Any current project will be saved and closed 
first.



Project Close

This option closes the current project. Any open files will be saved.



Project Add File

This option allows you to add Text or Bitmap Files to you project. 

Text files are assumed to have the extension *.doc, but this can be overridden.

It is suggested that you create your original text files with the extension *.txt, using Help Edit, 
Notepad, or any ASCII test editor, then copy the file to *.doc, so that you have an original 
version as a backup.



Project Delete File

Use this option to remove any Text or Bitmap files from the project. You must remember that if 
you have created any Topics or Definitions using the file you have deleted, these will still be in 
the Project, and if you reference them, the help compiler will complain.



Project Remove Topic

A Topic can be removed in one of two ways.

Method One. Select the Project menu and choose remove Topic, next select the Topic to remove 
from the list. 

Help Edit will search the current file and try to locate the topic, if successful it will ask you to 
confirm that the Topic be deleted. If you agree, the Topic information will be removed from the 
project, and the Topic marker deleted from your file. If it cannot find the marker, the Topic 
cannot be deleted until the correct file is loaded.

Method Two. Select the Topic marker you wish to remove from the project. Do not select onto 
the next line. Choose Remove Topic from the Project menu. Help Edit will read the selected 
topic marker, find it's title, and ask you to confirm removal. The Topic marker will then be 
deleted, and the Topic removed from the project.

Help Edit will not delete the text, in case you want to use it, remember that this text is now part 
of the preceding Topic. Help Edit does not remove any references to the Topic from your file, 
however the Topic marker is copied to the Search facility, and if you move to the start of the file 
and choose search, the search text contains the marker, search though the present file, and any 
others, to locate references to the Topic just removed.



Project Remove Definition

A Definition can be removed in one of two ways.

Method One. Select the Project menu and choose Remove Definition, next select the Definition 
to remove from the list. 

Help Edit will search the current file and try to locate the Definition, if successful it will ask you 
to confirm that the Definition be deleted. If you agree, the Definition information will be 
removed from the project, and the Definition marker deleted from your file. If it cannot find the 
marker, the Definition cannot be deleted until the correct file is loaded.

Method Two. Select the Definition marker you wish to remove from the project. Do not select 
onto the next line. Choose Remove Definition from the Project menu. Help Edit will read the 
selected Definition marker, find it's title, and ask you to confirm removal. The Definition marker 
will then be deleted, and the Definition deleted from the project.

Help Edit will not delete the text, in case you want to use it, remember that this text is now part 
of the preceding Definition. Help Edit does not remove any references to the Definition from 
your file, however the Definition marker is copied to the Search facility, and if you move to the 
start of the file and choose search, the search text contains the marker, you can therefore search 
though the present file, and any others, to locate references to the Definition just removed.



Project Current :-[None]

This Menu simply identifies the current project, or [None] if no Project is active.



How To change the Default Editor.

From the main menu bar select Options, then choose Editor.

Use the file dialog box to select a new editor to be used to view error messages from the Help 
Compiler. The default is Notepad. Help Edit will remember your selection and use it in future 
sessions.



How to Launch a program

If you are using the version 3.1 of the Help compiler, you can run programs from within your 
help file.

A program can be run by creating a hotspot link using a word or phrase, or even a bitmap. To use
text, select the text using the left mouse button, then select Program from the Insert Menu. You 
will be presented with a dialog box requesting the program details. Enter the program name and 
any optional command line parameters. For example to run Word for Windows and to open the 
file MyFile.doc you would type Winword Myfile.doc into the edit field.

To run a program from a Bitmap select the Program radio button option when inserting the 
Bitmap into your document. You enter the program details as before into the edit box provided.

For more information refer to the section on inserting Bitmaps.



How To Create An Alias List

You use the [Alias] list to assign one or more Topic labels to the same Topic alias. Because Topic
labels must be unique for each Topic and can't be used for any other Topic in the Help project, 
the Alias list provides a way to delete or combine Help Topics without re-ordering your files. The
Alias List is optional.

For example, if you create a Topic that replaces three other topics, and you delete the three, you 
will have to search through your files for invalid jumps to deleted Topics. You can avoid this 
problem by using an Alias list to assign the new Topic to the deleted Topics.

You can also use the Alias List when your application program has multiple context identifiers 
for which you have only one Topic. This can be the case with context-sensitive Help.

To create an Alias List you should create a simple ASCII text file with the same name as your 
Project file, but with the extension .ALI. Help Edit looks for such a file when compiling the .HPJ
file, and if found, it is included in the .HPJ.

An example is shown below, note that comments can be included if separated from the Alias 
information by a semi-colon.

sm_key=topic0001
cc_key=topic0001
st_key=topic0001;combined into keyboard shortcuts topic
clskey=topic0002
makey=topic0002;covered in using dialog boxes
chk_key=topic0004

The Topic label is the same as the Topic code eg topic0010 that is placed above the Topic text by
Help Edit, but minus the special marker.



Paragraph Indent

Use this option to create indented paragraphs that will maintain their alignment even if the 
Help Window is reduced thus causing word wrap onto the next line. To indent a paragraph 
first select the text to be indented, then choose Paragraph Indent from the Insert menu.

The above paragraph is an example of what is available.



    Make Topic

This option is used to create Topics from your text file. You should start by placing the caret (text
cursor) at the beginning of the topic text. Now selecting the Make Topic menu option will 
present you with a Dialog box which asks for a Title for the Topic, a list of Keywords, and a 
browse sequence parent and number.

The Title is used to reference HyperText links to this topic from other parts of the Help system.

The Keywords are used by the help system search facility, multiple keywords can be entered, but
you must place a Semicolon between each keyword.

Under the Keywords entry there is a drop down list box titled Keyword Index, and it has an 
Accept button to the right of it. If you have created an index list using the program Index-It, 
and this index file is in your Project directory, then these two controls will be active, and the 
Keywords Index List box will contain a list of Keywords.

If you have not created such a list, then the controls will be disabled, and you should ignore 
them.

Index-It is a program that scans text files, and allows the user to build lists of words that could 
be used as Keywords or Index words. If you have such a list present when Help Edit loads your 
Project file, them the Index List will be read also.

Now, instead of thinking of keywords, you can select a word from the list, and click the Accept 
button to insert the word into the Keyword control. If more than one word is entered they will 
automatically be separated by a semi-colon. You can off course edit this field manually as well as
automatically. You can clear the field by clicking the clear button.

The Browse sequence allows you to group related topics together. Using the browse buttons in 
the help system, a user can jump forward and backward between related topics in a sequence that
you have defined.

The parent is the reference to the start of the browse sequence, and the number the order of the 
sequence. Refer to Making a Browse sequence for details of how to create these links.

Experienced users may prefer to use the Accelerator keys Alt+T, or the Toolbar button, instead of
selecting the menu. The Topic Toolbar button is the one like a Page.

A third method is to click the right mouse button once the cursor is in place at the start of the 
topic, the cursor must be in the left most column, ie column 1.

Help Edit will place a Topic marker in your file. All text after this marker will be considered part 
of the help topic until either another topic or definition marker is located, or the end of the file is 
reached.





Make Title

Make title simply marks the selected text to be produced in Bold type so that it stands out from 
the rest. Although intended for Topic titles, it can be applied to any selected text that you wish to 
appear in Bold. You may use F4 instead of the menu.



Make Definition

Make definition allows you to add lookup references in order to define words or phrases. You 
would normally put all definitions in a separate file, and create them at the same time. 

Definitions are created in a manner similar to creating Topics. Place the caret (text cursor) at the 
start of the definition text, then select Make Definition from the Make menu. If you prefer you 
can use the hotkey Alt+N or click the Pop-up Toolbar Button (looks like a Page with a Pop-up 
window) instead. You will be presented with a dialog box requesting the word or phrase you are 
defining. Later in your help file you will add a definition link, and select this word or phrase 
from the list.

When the user clicks the left mouse button on this word or phrase, (which will have a dotted 
green underline), then the definition text will pop up in a window, to give an explanation of the 
word or phrase.



Make Help File

This option produces a Windows Help file based on the information in your project.

Select this option from the menu, by pressing F2, or by clicking the Toolbar button, the one that 
looks like a magic wand. If your edit text has changed you will be prompted to save it first as 
Help Edit uses the text in the disk file, not the editor. You should save your work if you want the 
changes to be included in this make.

You will be presented with a dialog box that requests a Help Title, a Main Index, a default font, 
and whether or not the Help file should be compressed.

The minimum entry is a main index, which you select from the list of Topics you have created.

Type in the Title caption for your help file, do not add the word Help after the title as the Help 
compiler does this automatically once it is compiled. The next box tells the help system the name
of our main index or contents topic, select the Topic to be used as a Main index. The Default 
Font option sets the help file font, this font is used when no other has been selected. The 
compression option should be checked once you have fully tested and debugged your help file.

Click OK or press enter and Help Edit will compile your document file into an RTF file. It will 
also create an *.HPJ called <ProjectName>.hpj, and then invoke the help compiler. During this 
process Help Edit will become an icon and will be disabled until the help compiler is finished. 
The Help compiler will also be an icon, but you can restore it to a window if you wish. As it is 
rather boring you would be best spending the time working on something else.

Once the help compiler is done, the DOS icon will vanish, and Help Edit will restore.

If all is well you will get a simple message box telling you that the compilation is finished. If any
errors have occurred then Help Edit will invoke your windows Editor to show them. The default 
editor is Notepad, but you can change this to any other editor or word-processor by selecting the 
Options menu, Helpedit will remember the editor you have selected and use it from then on.



Default Font

HelpEdit sets the default Font of your Help file to Arial. You can select another Font by choosing
one from the list of Fonts presented in the Make Help File dialog box.



Insert Jump Link

This option is used to create HyperText jump links between the Topics that you have created. 
First select the text to make into a jump link, then choose Insert Jump link from the menu, or 
press Alt + J. 

Select the text by dragging the mouse cursor over the text with the left button pressed. If only a 
single word is being used as the jump link, you may double click on the word to select it.

Once text is selected you can make a jump link by selecting the menu, using the accelerator keys 
Alt + J or by clicking the right mouse button.

A dialog box will appear showing a list of all the available topics for the project, even if they are 
located in another file. You should select the topic you want the user to jump to when he/she 
clicks on this word or phrase. 



Insert Definition Link

This option is used to create HyperText definition link . First select the text that you wish to 
make into a Definition link, then choose Insert Definition link.

Select the text by dragging the mouse cursor over the text with the left button pressed. If only a 
single word is being used as the jump link, you may double click in the word to select it.

Once text is selected you can make a Definition link by selecting the menu, using the accelerator 
keys Alt + D.

A dialog box will appear showing a list of all the available definitions for the project, even if 
they are located in another file. You should select the definition you want to appear when the 
user clicks on this word or phrase. 



Insert Bitmap Image

This option is used to insert a Bitmap image into the help file.

Help Edit support the inclusion of 3 types of Windows Bitmap.

Windows Bitmap (.BMP)

Placeable Windows metafile (.WMF)

segmented-graphics bitmap (.SHG)

First position the cursor at the text location that you wish to place a bitmap, then choose Insert 
Bitmap Image. do this by selecting Bitmap Image from the Insert Menu, using the hotkeys 
Alt+B, or clicking the Toolbar button, the one with the picture on it.

A dialog box appears giving a list of all the available Bitmaps for the project. You should select 
the Bitmap file you want inserted at this point. If you are unsure of the bitmaps you have, then 
select a bitmap in the list box, and then click the Preview button to see what the image looks like.
It the image is small enough to fit into the viewer, it will appear full size, and centred in the view 
window. If the image is too big, it will be squashed to make it fit. Although this will distort the 
image, it should be possible for you to at least recognise if you have selected the correct image. 
This is only for .BMP bitmaps.

There are three radio buttons to the left of the list box marked Left, Centre and Right. This 
determines how the image will be placed relative to surrounding text. Refer to your help 
compiler manual, or look at the Tutorial for an example.

Bitmaps can also be used as Hotspots in the same way words or phrases are used to jump to 
another Topic, pop-up a definition, or ( if Windows 3.1) run a program (applies only to .BMP and
.WMF files, .SHG files already contain this information).

To make a bitmap a jump link, select the Jump radio button, and then select the name of the 
Topic to jump to from the list box.

To make a bitmap a Definition link, select the Definition radio button, and then select the name 
of the Definition to show from the list box.

To make a bitmap a run a program, select the Program radio button, and then enter the program 
details into the edit field. You may enter a program name and command line parameters, eg. 
notepad.exe myfile.txt.

To make use of a Segmented-graphics bitmap you should refer to the documentation for your 
Hotspot Editor. In order to get the context strings for the Hotspots, you should first create you 
help file and it's topics. Then look at the .HPJ file [MAP] section. There you will find the context
names, context numbers (used for context sensitive help), and the Topic titles. Make a note of the



context strings, and later use them as input in your HotSpot editor. If you are using Borland 
compilers, the Hotspot Editor is called SHED.EXE.



Help About

This menu option displays a dialog box showing the version number and Copyright information 
for Help Edit.



Help Index

This menu option invokes the Help system and brings up the main index or contents page for this
help file.



Help on Help

This option starts the Help engine and gives the user new to Windows information on how to use 
Windows Help.



Help Order

This option is only available in the Shareware version of Help Edit, it gives information on how 
to register your copy of Help Edit.



Help Shareware

This option is only available in the Shareware version of Help Edit, it gives information on the 
Shareware principle.



Help Tutorial

This option runs a simple step by step tutorial help on how to create a help file.



Help Test Help

This option allows you to test your newly created help file by invoking the help engine and 
passing it the name of your help file. You can perform the same operation by clicking the Spy-
glass button on the Toolbar. If you do not have a project open, or if the help file does not exist, 
you will be presented with a file dialog box asking for the name of the help file that you want to 
test.



How to prepare your Help File

You can use any word-processor    that can save the file in plain ASCII format. You could even 
use Notepad or Help Edit itself. This file was produced using Works for Windows, as a *.wps 
file, and then after spell checking, it was saved as a plain ASCII *.txt file. The *.txt file was 
copied to a *.doc file, and this file was input to Help Edit. It is always a good idea to keep a copy
of your original text file.

If you have the professional version of Help Edit, you will have the Spelmate spell checker 
installed, and you could use this Instead.

Help Edit is limited to a maximum size of around 30K for any single text file. However you can 
split your project into several files, and from a management point of view this is probably a 
better idea. This help project is in three files, Helpedit.doc,HlpEdit2.doc, and Defines.doc.

The first thing to do is to create your text documents if they do not already exist. Then decide on 
any definitions that you think might be needed. You can alter the flow of things as they develop. 
Do not feel that you must plan every detail at the start. Help Edit was designed to make the 
creation of Help Systems as simple as possible. Once you have your raw material, it is time to 
begin your Project.



How to create a Help Edit Project File

This is very easy. From the Project menu choose Open, and type in the name of your new 
project, rather that selecting one from the list. The file extension is not needed as it will 
automatically be set to *.prj, and the new project will be created. At this point it is empty.

You can begin by simply typing your text into Help edit, and when you save your work, the file 
name will be added to the project.

Alternatively you can add existing text or    bitmap files to your project.

To add text files select Add File from the Project menu, and choose Text file. You will be given a 
file list of all *.doc files. This is the recommended extension but you are free to choose not to 
adhere to it.

You can add Bitmap files to your project in a similar manner.

Now you are ready to start creating Topics and Definitions.



How to create Help Topics

Start Help Edit and load a project if one is not already loaded, or create a new one. Open the first
text file and position the cursor at the start of the text to be made into a Topic.

Make a Topic in one of four ways.

1.    Select    Topic from the Make menu.

2. Press the Accelerator Keys Alt + T.

3. If the cursor is in the Left most column click the right mouse button.

4. Click the Topic button on the Toolbar.

A Topic dialog box will appear which you should complete to make a topic.



How to create Help Definitions

Start Help Edit and load the project if it is not already loaded. Open the first text file and position
the cursor at the start of the text to be made into a Definition.    Choose Definition from the Make
menu.



How to create Jump Links

Before you can create jump links you must have created at least one Topic.    To make a jump 
link select the text that you wish to make the activator, and then select Jump from the Insert 
menu.

Select the text by dragging the mouse cursor over the text with the left button pressed. If only a 
single word is being used as the jump link, you may double click in the word to select it.

Once text is selected you can make a jump link by selecting the menu, using the accelerator keys 
Alt + J or by clicking the right mouse button.



How to create Definition Links

Before you can create definition links you must have created at least one Definition. To make a 
definition link select the text or phrase that you wish to make the activator, and then select 
Definition from the Insert menu.

Select the text by dragging the mouse cursor over the text with the left button pressed. If only a 
single word is being used as the definition link, you may double click in the word to select it.

Once text is selected you can make a definition link by selecting the menu, using the accelerator 
keys Alt + D.



How to create a Browse Sequence

Browse sequences allows the user to move between topics in a pre-defined order, perhaps 
because it is more logical for them to do so, rather than allow them to jump about in whatever 
manner they want.

Browse sequences also allow related Topics to be grouped together, when you want to make it 
easier for the user to move to the next Topic.

Before you can implement a complete browse sequence you must first have created some topics 
text. Start with the first Topic in the browse sequence and make it into a normal Topic. The 
default parent is itself, and the browse number should not be entered, as it will be set to zero by 
default.

Create the next Topic that you want to be in the sequence. This Topic may be accessed in the 
normal manner via a Jump, or it can be accessed from the first Topic by setting it's parent equal 
to the title of the first topic, and it's number equal to the position in the sequence that you want to
appear.

It is a good idea to increment the sequence numbers by 10 or 20 at a time, so that you can insert 
other numbers in between later if required. Once a sequence has been created, the Topics will 
move backward and forward in the order of the sequence numbers that you defined, when the 
user clicks on the backward and forward browse buttons.

This is explained in detail in the Microsoft Help compiler manual, and is also covered by an 
example in the Tutorial. 



How to include Fonts and Colours.

First select the text you wish to have in a different font or colour. Then select Choose Font from 
the Options Menu. 



How to include Bitmap Graphic Images

You can include bitmap images in your help file using the Insert Bitmap Image option. Use 
Windows paint to create the bitmap, but be sure to save only the absolute minimum bitmap size, 
use the cut to function of the Paint Edit menu to save a portion of the whole paint image. 
Bitmaps greater than 64K will not be accepted by the help compiler (Microsoft Problem).

To insert Bitmaps position the cursor at the place where you want the bitmap to appear and select
Bitmap Image from the Insert menu.



How to Make a Help File

Select HELP File from the Make menu, or press F2, or click the Spy-glass button on the Toolbar
. You must have a current project loaded.



How to use HC.BAT

The Microsoft Help compiler HC.EXE is used to create Help files for the Windows Help system.
This is a DOS based program that requires a project file with the extension *.hpj to direct it's 
operation.

Help Edit automatically creates this project file for you when you make a help file.

There are currently two versions of the Help Compiler (at least!), one for Windows 3.0 and a 
later one for Windows 3.1.

Some suppliers such as Borland ship both compilers for backward compatibility under the names
HC30.EXE and HC31.EXE, and use a batch file called HC.BAT to allow the user to select the 
appropriate version, depending on a command line switch. (I believe MS may also be shipping 
under these names).

This approach has been taken by Help Edit so that if the help compiler name should change, 
Help Edit always calls HC.BAT, and the user can edit it to call the correct compiler.

If you do not have the files HC30.EXE or HC31.EXE but only HC.EXE you must Edit HC.BAT 
to change the name of the compiler. Help Edit will call HC30.EXE if the Windows 3.1 menu is 
unchecked, otherwise it will call HC31.EXE by passing the an extra parameter to the HC.BAT 
batch file. 

If your compiler HC.EXE is version 3.0 then change the reference to HC30.EXE to HC.EXE, 
and if it is version 3.1 change HC31.exe to HC.EXE. You can find out the version from your 
documentation, or just by running it and looking at the copyright message. Remember to check 
the Windows 3.1 menu item under Options if you are using the 3.1 compiler when making a help
file.

If you Registered Help Edit you will have been sent copies of both Help Compilers (now in the 
Public Domain), and therefore the HC.BAT file will be set up correctly. You need only make 
changes if you already have a copy of the Help Compiler, and don't want to have two copies 
using valuable disk space.



How to Edit A Topic

If you want to change any aspect of a Topic, for example alter the Keywords, or change the 
Browse sequence, you should select Topic from the Edit Menu.



How to Edit a Definition

If you want to change the Title of a Definition, you should select Definition from the Edit Menu.



How to Remove a Topic

To Remove a Topic from your project, select Remove Topic from the project menu.



How to Remove a Definition

To Remove a Topic from your project, select Remove Definition from the project menu.



How to Create an HPJ Project File for HC

You must have a valid project file open, and it must contain at least one text file. Select HELP 
file from the Make menu and complete the dialog box. The *.HPJ file is automatically created by
Help Edit prior to running the Help compiler.



How to Make Context Sensitive Help calls

Help Edit adds context sensitive information to the HPJ file in the MAP section. This consists of 
Topic labels, a context number, and a comment fields, which is in fact the Topic title, so that you 
can identify it.

From your Windows application you would call the help engine with the HELP_CONTEXT 
wm_command parameter, and the context number of the topic you want to display. NOTE: the 
numbers are in HEX.

In C you would write
WinHelp(hWnd,szHelpFileName,HELP_CONTEXT,context_id);

and in Pascal
WinHelp(Wnd,HelpFileName,HELP_CONTEXT,context_id);

where context_id is the Hex context number of the Topic you want to show, and you would get it
by looking in the [MAP] section of the HPJ file of your project.

szHelpFileName (or HelpFileName) is the name (including path) of your help file you want 
WinHelp To run.

HELP_CONTEXT is a command switch to WinHelp.



How to test your Help File

From the Help menu select Test Help, or click the Spy-glass button on the Toolbar.

If you have a current project Help Edit looks for a Help file of the same name but with the 
extension *.HLP. If no project is open, or if Help Edit fails to find the file, an Open file dialog 
box appears to allow you to select a Help file to test. Help Edit will then invoke WinHelp with 
the file chosen.



Defined Terms

Browse
Definition
HPJ
HyperText
Keywords
Project
RTF
Shareware
Topic




